Incorrect Zones on Garmin workout

I am having an issue where my Training Peaks imported workouts show different power on my garmin than what is shown on the TP plan.

Am I missing something?

Your FTP needs to be set the same in each program.

Thanks Mark, FTP is correctly set on both my Edge 1030 and my TP account. Same for Power Zones

I would have said the same as Mark.

Have you updated your FTP recently? I know sometimes a workout can be saved in the Garmin and will work off the old FTP setting.

I did. And after that I tried re-setting the connection to training peaks so it would pull the workouts with the new values but I don’t think that did the trick.

1 Like

Ok, I figured it out. Just in case anyone faces the same problem, here is the issue:

After you change the FTP on Training Peaks, it will update all of the workouts there but it will not push to Garmin Connect automatically. For it to happen you will need to make a manual change to the workout…which is a pain if you need to do it for an entire training plan.

So what I did was going to TP, removing the training plan and re-adding it. Everything pushed to Garmin connect with the new values and I am good to go.

Hope this helps.


Thanks for sharing!

I tried to reset my 1030 as a different approach but that didn’t work so don’t do that. Ended up just exporting all the workouts until the next Field Test and copying them to the 1030. Worked but not as easy I’d imagine. Suppose it depends if one customizes their plan at all.

1 Like