Zwift not syncing

i synced and connected zwift with TP and it worked for a couple workouts, now it won’t connect
I have missed 3 workouts
I have restarted my computer and restarted the trainer, still no connection. The workouts are not found in Zwift

Hey Rick,

Here’s our training tip on getting things synced between trainingpeaks and Zwift How to sync TrainingPeaks with Zwift for Indoor Training - YouTube

Which plan are you doing? If the workout does not have the different power block built out for the day, it will not sync from Trainingpeaks to Zwift.

While you are troubleshooting this, there is a manual way to build workouts in zwift, or setting Zwift into free ride workout mode will let you choose your own intensity - if you can pedal your bike on the trainer, then you should not be missing workouts, you can hit them oldschool style.


I am using the30 week sweet spot weight training plan
I am on muscle tension intervals 3x12

should this one sync?

yes, it should be syncing to Zwift. Check your connections and make sure that the email address in trainingpeaks is the same as what you’ve connected your Zwift account to.

yep, I have disconnected and re-connnected, restarted the computer …
should I just see if it works tomorrow?

yes i’d do that - 3x12 is an easy workout to create for yourself. If it’s not working tomorrow i’d contact Zwift support, it’s difficult for us to troubleshoot two other companies’ syncing issues

Rick, You’re not alone here. Same issue I experienced. I think a Zwift s/w update that happened earlier this week ‘might’ be the issue. My workouts haven’t loaded the last 2 days after Zwift updated. I just did a google search on the topic, and it seems the recommendation is to disconnect the Zwift->TrainingPeaks connection from Zwift web app, then to re-connect.
Will see if it fixes the issue tomorrow.

1 Like

It’s tomorrow for me, and it still doesn’t connect. I will try and contact Zwift and see if they can help. Thanks for your information.

I just tested out this theory as well, and it did not resolve the issue either

From Zwift Forums…

[Shuji] Community Forum Manager

Thanks for reporting back everyone. We also are seeing this impacting PC and macOS platforms.

For now - if you are able to use a smartphone / tablet / AppleTV to Zwift, it seems that Training Peaks workouts are showing up on those platforms.

Stay tuned - we’ll update this thread as we make progress towards a fix.


The recent Zwift update seems to have addressed the issue with loading workouts

thank you Brad, all is good

1 Like