Turning training peaks green

This morning I did my mtb 3x15 on my mtb on trails. When I look at training peaks it categorized the workout as “road cycling” and did not count towards today’s workout. I changed the category to “mtb” but yet it still doesn’t get recognized as today’s workout. Any ideas on how to fix this or at least prevent it in the future?

@chad.davis You should just be able to drag one workout onto the other to pair them since one of them has no file attached to it… Otherwise,

Fix: download the road cycling file from the files button, then delete it from TP. Then upload the file to the scheduled workout using the files button.

Prevent: I don’t know.

1 Like

Okay, I’m assuming this needs to be done from a computer, I’ll give it a try this afternoon. Thanks!

1 Like

There’s a tab in settings which allows you tick the boxes beside different activities of your choosing. Maybe road cycling is the only one ticked.
If so just tick box for “All activity types” or select MTB and road cycling.

1 Like