"Power too high", "Power too low" alerts on Garmin

Hi all- I’m on a FasCat training plan that I upload from TrainingPeaks to my Garmin 820. Here’s my problem: when I’m doing a workout with prescribed power zones, my Garmin beeps at me approximately 1000 times during the workout, with “power too high” or “power too low” alerts. I try to avoid stoplights and such, but due to changes in hill gradient and other factors , my power inevitably dips below or goes above the specific zone–even for one second–and Garmin does NOT like that. I know my target power, and think I’m doing a good job of staying generally within the zones… I just want the beeping to stop!

The only solution I’ve found is to turn off all alerts on my Garmin, but then I lose the lap beginning and ending chimes too (which I’d like to keep). Note that even with this “solution” there are still annoying visual alerts that I’m not exactly within my prescribed zone. Is there any workaround? When I’m creating a workout from scratch, I typically leave out the target power for each lap, and just make sure the lap durations are correct (and that I know what power I need to sustain for each lap).

Is there a version of the training plan like that (for the exported workouts at least)? If I switched from my Garmin to a Wahoo bike computer, would that potentially solve the problem? Or do I just have to manually duplicate all the workouts and omit the power targets?

Thanks much!
Rob

Maybe someone who has used this feature can chime in but with my quick research you are not the only one frustrated with this feature. At this time there is no time to turn off the notifications when a you are following a workout.

I would just try to remember the workout and just ride. Most of our workouts are pretty simple to remember as there are not multiple steps. Usually just one main set of intervals to do. Some riders will put tape a piece of paper to their stem with the workout so they remember. But again typically just a few steps in our workouts.

That is what I do and then I will just hit the lap button. On my Garmin I have a page that is just lap time, power, heart rate, cadence, and lap distance. On another page I have ‘lap power average’ this way I can see how I preferred the interval.

hmm, I upgraded from a 520 to a 530 in August 2019 and the 530 doesn’t beep at me like that. For example Last night I rode for 12+ minutes above target power and I only received 2 or 4 “power to high” alerts. I’ll look at my config and report back.

I go in and alter the watt targets to a range rather than a set number and change the upper limit to 900 watts on the work intervals. I also change the recovery target range to 1 - 900 watts.

2 Likes

I read about a lot of people doing that.

Awesome, thanks everyone! I guess there are a couple of pretty simple workarounds. Just wanted to make sure I wasn’t missing something obvious!

Ok I’m using this on a 530 and it may not look or work the same as on the 820 (guessing its similar as my old 520).

First off on the Activity Profile I have all alerts disabled except for hydration and fueling:

273

During a workout the screen looks like this (in garage, power meter connected but not turning pedals):

511

And I may see “power too low” or “power too high” warnings from time-to-time, not annoyingly like when alerts are turned on, however that warning only covers up the small bottom 20% of screen where the Duration 00:02:30 is in the screenshot. :+1:t3:

:biking_man: :biking_man: :biking_man:

The other thing I do is before the ride it takes about 2 minutes total to create just the intervals in Garmin Workout creator. I call that a “Workout Snippet” and its also kinda nice to have these on head unit if I want to do some intervals on a weekend ride since there are no group rides. Or pre-COVID when I ride for an hour to the ride start and want the target screen.

For example here is the original prescribed 4x8 sweet spot w/bursts:

and just the intervals in Garmin Workout creator (web or mobile app):

As you can see, I only captured the intervals and left out warmup, endurance work, and cool down.

Then start a ride and eventually leave the city limits… now hit upper right button and select the workout snippet. Do the work and the workout finishes and I continue riding back home. All captured as a single ride file.

After ending and saving the ride, this is what I see on 530:

45

which I like as it focuses attention on intervals and not on warmup and potentially any extra time before/after the intervals.

in Garmin Connect its nicely aligned:

while default post-ride view in TrainingPeaks:

is a little messy and we can make that look better by shifting the prescribed left/right in TrainingPeaks using the blue controls in upper right of screenshot:

Suppose I could have hacked the interval prescription in TrainingPeaks, but I like keeping it as reference and I’ve been creating workouts using Garmin mobile and web apps for 4 years.

1 Like

On structured workouts I stay on the workout screen & have the audio alarm turned off. I focus on keeping my power in the green zone. This seems to work for me, inside or out. Inside is way easier though. I miss seeing some of my other metrics like cadence & HR, but it works. Garmin 520.

These alerts drove me nuts on the first couple of outdoor workouts that I did with my Edge 520 Plus. It was to the point of turning off the workout and manually hitting the lap buttons and watching my power target.
The workout screen itself is okay but only shows power and lap duration. You can’t see HR or cadence information which I always prefer to have viewable.

Here is how I solved on my 520 Plus:
Settings -> Activity Profiles -> (Select your profile, “Train” for me) -> Alerts -> Turn off “Workout Target Alerts”

garmin_screen
Worked perfectly and no annoying full screen messages every 10 seconds.

3 Likes

Thanks again for all of the feedback everyone. I mis-stated my model number in my original post… it’s the Edge 810, not the 820. And for some reason my alerts menu doesn’t have “workout target alerts”! I checked that I had the latest firmware and everything. The best solution I’ve found is to just remember the target power (or zone) for each interval and modify the workouts in Garmin Connect to not have an explicit power target. That way I still get the starting and ending beeps, but nothing in between.